You are here

Cross Probing between OrCAD Capture and Allegro PCB Editor

Overview

Module 1: Configuring OrCAD Capture and PCB Editor for Cross Probing

Lab 1: Enabling ITC in OrCAD Capture

Lab 2:  Setting display_nohilitefont preference in PCB Editor

Lab 3: Launch PCB Editor from within OrCAD Capture

Lab 4: Adjust PCB Designer display

Module 2: OrCAD Capture- PCB Editor Cross Probing

Lab 5: Cross highlighting from OrCAD Capture to PCB Editor

Lab 6: Cross probe from PCB Editor to OrCAD Capture

Lab 7: Cross selecting between OrCAD Capture and PCB Editor (Schematic-Driven Component Placement)

Module 3: More with Cross Probing

Lab 8: Enable/Disable cross probing for global nets

Summary

Overview

Cross probing refers to the ITC between OrCAD Capture and Allegro Design Entry. It is used to point the object in one tool and select the corresponding object in another tool.

TOC

Module 1: Configuring OrCAD Capture and for Cross Probing

Lab 1: Enabling ITC in OrCAD Capture

1. Open OrCAD Capture.

2. Open the Preferences dialog box using Options > Preferences.

Figure 1

3. In the Preferences dialog box, highlight the Miscellaneous tab, enable ITC, and select OK.

Figure 2

Lab 2: Setting display_nohilitefont preference in PCB Editor

Note: You can also set the preference later when OrCAD Capture will invoke PCB Editor for cross probing.

1. Open PCB Editor.

2. Open the User Preferences Editor dialog box using Setup > User Preferences.

Figure 3

3. In the User Preferences Editor dialog box, expand Display in Categories and select Highlight. Check the Value box for the preference display_nohilitefont. Now, select Apply and then select OK as shown in FIG 4.

Figure 4

Lab 3: Launch PCB Editor from within OrCAD Capture

1. Open the project using File > Open > Project.

Figure 5

2. In the Open Project window, browse to the \bench.dsn project file and click the Open button.

Figure 6

3. Select the bench.dsn file in Project Manager and netlist the design using Tools > Create Netlist.

Figure 7

4. In the Create Netlist dialog box, select the PCB tab. Enable the checkbox for Create or Update PCB Editor Board (Netrev). In the Input Board File field, browse to …\bench_allegro.brd; and in the Output Board File field, enter xprobe.brd. For the rest of the Create Netlist dialog box settings, refer to FIG 8.

Figure 8

5. If the Product Choice dialog box appears, select PCB Designer and then click OK.

Figure 9

6. This will open PCb Editor with the xprobe.brd file derived from the Input Board File setting.

Figure 10

Lab 4: Adjust PCB Designer display

1. For better visibility, turn off grids using the Grid Toggle button.

Figure 11

2. Enable General Edit mode using Setup > Application Mode > General Edit.

Figure 12

3. Change the Rat color to orange using Display > Color/Visibility. Select Apply and OK to implement the changed color settings.

Figure 13

4. Resize and arrange the OrCad Capture and PCB Designer windows so that they are both visible and are placed side-by-side.

Figure 14

TOC

Module 2: OrCAD Capture - PCB Editor Cross Probing

Lab 5: Cross highlighting from OrCAD Capture to PCB Editor

It applies on three different types of objects: Parts, nets, and pins.

1. Select any logical element using LMB in OrCAD Capture and notice that the corresponding element in PCB Designer is highlighted and fit in the window.

Figure 15

2. Window-select a group of nets in the schematic and notice that the corresponding nets are highlighted in PCB Editor.

Figure 16

3. Repeat the above 2 steps for the other logical parts (Pins and Parts) and notice the highlighting behavior.

Note: This example shows how rats are highlighted in the board during cross probing. If the board is routed, the trace would be highlighted also.

Lab 6: Cross probe from PCB Editor to OrCAD Capture

1. Enable the Highlight option using Display > Highlight.

Figure 17

2. Enable the checkbox for the Nets object only in the Find filter tab.

Figure 18

3. Now, select any rat net in the layout and notice that the corresponding net in the schematic is highlighted and fit in the window.

Figure 19

4. End the Highlight command in the PCB Editor canvas; then, RMB and select Done.

5. Try the above steps on other logical objects like part/pin and notice that the corresponding object is highlighted and fit in the window.

6. To deselect the selected object, enable the Dehighlight option using Display > Dehighlight.

Figure 20

7. Now, deselect any selected object in the layout and notice that the corresponding object in the schematic is dehighlighted.

8. End the Dehighlight command in the PCB Editor canvas; then, right-click and select Done.

Lab 7: Cross selecting between OrCAD Capture and PCB Editor (Schematic-Driven Component Placement)

1. Configure PCB Editor: Export part library using File > Export > Libraries.

Figure 22

3. In PCB Designer, enable General Edit mode using Setup > Application Mode > General Edit (as shown in FIG 12).

4. Delete all parts on the board. Select Edit > Delete and window-select all parts.

Figure 23

5. In the PCB Editor canvas, finish the Delete command using right-click > Done.

6. Next, place the parts from the schematic onto the board. From the PCB Designer pull-down menu, select Place > Manually.

Figure 24

7. Using the Ctrl key, select the parts in the schematic and move the cursor into the layout to place the parts.

Figure 25

Notice the logical-to-physical mapping during schematic-driven placement.

8. In PCB Editor, complete the placement command using RMB > Done.

TOC

Module 3: More with Cross Probing

Lab 8: Enable/Disable cross probing for global nets

You can enable/disable cross probing for nets like GND, VCC, and so on and can still cross probe other nets, pins, and components in the design.

1. Open the Preferences dialog box using Options > Preferences as shown in FIG 1.

2. Select the More Preferences button in the Preferences dialog box to open the Extended Preferences Setup dialog box.

Figure 26

3. Under Design and Libraries, uncheck Enable Global Net ITC.

Figure 27

TOC

Summary

This RAK described the basic steps to perform cross probing between OrCAD Capture (Design Entry CIS) and PCB Editor.