You are here

Various BOM reports in Capture CIS





Capture BOM

CIS BOMs

Variant Reports

Crystal Reports

What is a Variant?

Relational database and its configuration

References


Capture BOM

Capture BOM is a handy feature to create a BOM of a design with desired schematic- level properties. These properties can either be from library or added/defined in the schematic. In general, the basic properties like Part Number, PCB Footprint, Value, etc should be added at the library level so that all the designers are not required to add the properties at the schematic level. A designer can simply access these libraries from a corporate/shared location and use them in the design. In a typical design cycle, the librarian is responsible for maintaining part development by going through the datasheet or based on the request of a designer.

Capture BOM requires no additional configuration or data integration external to the tool. It takes just a few mouse clicks followed by property definitions to get a BOM ready.

TOC


Capture BOM GUI

The Capture BOM GUI is available from the Tools > Bill Of Materials menu command.

image

Figure 1: Capture BOM

Let’s look at the various options and fields in the Bill of Materials GUI which can be used to customize a BOM report

Field

Description

Scope:

BOM can be created for the entire design or selected page(s) or a selected schematic folder(s) by choosing the designated radio button in Scope section.

Figure 2 shows the different selection possibilities in Project Manager.

image

Figure 2: BOM-Scope

image

Figure 3: BOM-Scope. Project Manager showing different selections.

Mode:

The Mode section allows user to report property values from the Instance or

Occurrence level. For a flat or simple hierarchical design, the Preferred mode must be Instance, as shown in Figure 2 Use Instance). In this case, the property

values will be read from the white column of Property Editor. For a complex hierarchical design (where design has duplicated hierarchical blocks), the preferred mode should be occurrence (Use Occurrence) and the property values

will be read from yellow columns of Property Editor.

Note: Ideally for a flat or simple hierarchical design, preferred mode should be Instance. However, in case a user has edited any property value at the occurrence level, that is yellow column in Property Editor, the occurrence mode becomes the preferred mode. Or the property values must be same in white and yellow columns of property editor for a flat or simple hierarchical design. The thumb rule is that, if the selected mode is instance, properties will be read from the white column; else they will be read from the yellow column in Property Editor.

Line Item Definition- Header

Let’s spend some time to understand this section and how is it used to format a BOM report.

image

Figure 4: BOM-Line Item Definition

As the name suggests, it is the heading which is inserted/printed in final BOM report. These are the properties (column name) which are required in the report. Property names can be separated with a tab space by adding “\t“ between the names. For multiple tab spaces, add multiple instances of “\t”. If this field is left blank, Capture assumes that there is no header

Line Item Definition - Combined Property String:

Specify the properties that must match for Capture to group them in the BOM

report. Write all the properties enclosed within curly braces which should be shown in the BOM. The property name must exactly match with the schematic property name. Capture reads the value of that property from the design database (which can be seen in Property Editor) and writes to the BOM. The property values are listed in the same order as they are written in the Combined Property String field.

Again, to insert a tab space, use the \t character sequence. For example, "{Reference}\t{Value}" prints a part's reference, a tab character, and the part's value.

Place each part entry On separate line

Check this option to have one part per line. This BOM can be directly opened in MS-Excel from within the tool if the Open in Excel is checked.

Note: If the View Output option is checked, Open in Excel option appears to be inactive.

Include File

Non-schematic data could also be included in the BOM using an Include (.inc) file, which can be created in any ASCII text editor. This way you can avoid adding non-mandatory properties at the schematic level. The .inc file begins with a closed single quotes (‘‘) followed by the names of the additional columns. Text written in the first line of the .inc file appends into the BOM header. An Include file looks like Figure 5;

image

Figure 5: BOM-Include File Sample.

Combined Property String

The value of the property written in the Combined property string field within the Include file section is searched within single quotes in the include file.

image

Figure 6: BOM-Include File

For example, if VALUE is used as a Combined property string, then every line of include file must start with the value of the part enclosed within single quotes. Capture searches these values in the design and associates additional column in the BOM report as defined in the include file for the respective values.

In the above mentioned Include file, the intention is to use the Value property of various parts in the design and add additional information (manufacturers) which is not present in the design for all the parts with the values 10K and 20K. Therefore, every part with VALUE = 10K will have “company_1” and “company_2”, and parts with VALUE = 20K will have “company_3” and “company_4” added in the final BOM report. Header of the final BOM report will also have “manufacturer_1” and “manufacturer_2” as columns in addition to the properties defined in the header field which is shown in Figure 4.

Note: Any property can be used as a Combined property string. Make sure that value of that property is enclosed within quotes in every first line of the include file.

Due to its simplicity and ease, the capture BOM feature lacks a database interface like MS-Access, Oracle, etc. This reporting mechanism cannot read any property from the database even if the database is configured with CIS. As a result, the BOM cannot include any variant information. CIS standard BOM can read properties from the database using the CIS feature.

Capture BOM does not remember the Combined property string and Header and they should be defined for each project.

TOC


CIS BOMs

CIS BOM is a powerful feature which has the capability to read database (through CIS) and schematic-level data, and customize the final BOM report for better product analysis. However, for optimized product design, one should know which part is best suited for the design: is it available with the company? is it cost effective? and many such questions. Before we delve into the details of CIS BOM, let’s get a brief understanding of what a database looks like and how CIS plays an important role in interacting with the design and the database.

TOC


Database and its Content

image

Figure 8: Sample of MS-Access database.

Figure 8 shows the general content of an MS-Access database, which contains huge information about each part. This information may include company part numbers, part descriptions, PCB layout footprints, technical parameters (such as speeds, tolerances, and ratings), cost, and purchasing information. Generally, company hires a database administrator who maintains such data on real time basis and circuit designers are not bothered by how to insert such data. Here, all the properties are readily available to be configured as per user requirements. Using a single command like Update Part Status, a designer can verify the parts w.r.t the database. In the absence of such a database interface, these properties need to be defined at part level and the designer needs to modify the property value of every part. Starting SPB17.2, Cadence also ships a SQLlite sample database, BENCH.DB.

The sample database is present at the following location:

<Installation_dir>\tools\capture\samples\BENCH.MDB

Starting release 17.2, Cadence also ships a SQLlite sample database, BENCH.DB at same location.

TOC


Overview of Component Information system (CIS)

Capture CIS is a part management system that is an option in OrCAD Capture which provides access to local (preferred parts database) and remote part databases containing all the relevant information (Figure 8) on the parts used in a design. With CIS, the parts can be selected from the preferred parts database or a remote database and placed directly in the schematic design. CIS Configuration wizard allows you to transfer any or all properties associated with a part to the schematic when it is placed from the database. CIS maintains a link to the database part so that any other property of that part can be retrieved from the database at any time.

image

Figure 9: Capture CIS Overview

image

During the design cycle, a designer may be required to define some properties at the schematic level which are not within the company’s database. Under such circumstances, the designer can add properties at the design level and customize the Standard BOM to analyze the product.

TOC


CIS Standard BOM GUI

Let’s create a feature-packed report of all the components used by a designer and learn how to customize database- and schematic-level properties, to obtain variant properties, mechanical component details etc.

To access the Standard Bill of Materials GUI, choose Reports > CIS Bill Of materials > Standard.

image

Figure 10: Standard Bill Of Material

Field

Description

Template Name:

The list of properties can be arranged in the desired order. Select the Part

Reference options, Scope and do other customization and define the Template Name and save it.

image

Figure 11: CIS BOM –Template Name

If the same formatting is required again, you can select the saved template name from the Template Name drop-down list and reuse the settings.

Note: There is no file created corresponding to a Template, so it cannot be directly shared from one machine/user to another. The settings, however, are saved in the capture.ini file and can be copied. Capture.ini is present in the %HOME%\cdssetup\OrCAD_Capture\17.2.0 folder. Capture.ini location also gets logged in session loh when capture is started. This file has a section with the same heading as the <Template Name>. This entire section needs to be copied to the capture.ini file on the machine where this template is to be used.

Report Properties:

This section contains two sub-sections, Select Properties and Output

Format

Output Format: Lists the properties which will go to the BOM in same order as listed here. The user-friendly arrow keys help in sequencing the properties and customizing the BOM report as per requirements.

Select Properties: Lists all the available properties. Select a property and then select the Add button to populate the property to the Output Format section.

image

Figure 12: CIS BOM- Report Properties

  • The Yellow ( image) symbol shows that this property is being read from the configured database.
  • The Schematic symbol ( image) shows that this property is being read from the schematic.
  • Title symbol ( image) shows that this is a Title Block property.

Note: The database properties, which are not relevant in the circuit design process should not be transferred to the schematic. The database properties could be fetched and transferred to the CIS Standard BOM from the Select Properties list.

If any user-defined property is not listed here, you can type the name of the property in the Select Properties text field and select the Add button. If a match is not found, CIS BOM only shows the property name in the BOM; because no property exists with the specified name in the schematic, no values will be listed in the same column.

Once relational table properties are added in Output Format list, the Relational Data Displayed will list the Relation table data in CIS Standard BOM. The relational table data can be formatted in following two ways in the CIS Standard BOM;

  1. Horizontal
  2. Vertical

KEYED

Once the properties and their sequencing finalized, any of them can be marked as KEYED. CIS matches and then groups the records in the report

based on this property. The parts with the same value of the KEYED property

will be in same row in BOM. In general, part number should be set as KEYED, so that all the parts with the same part number are grouped together in the report. Any property can be marked as KEYED based on BOM requirements.

Allow Saving Title Block Properties

Select this option if you want to include the title block information in BOM.

Part Reference Options:

This section provides different grouping mechanisms in the report.

image

Figure 13: CIS BOM- Part Reference Options

Standard:

Use this option to group parts with matching KEYED properties on a single row.

Standard: Separate line per part:

Use this option to list each part on a separate row.

Compressed

Use this option to group the same parts on a single row and compress the part references into a range whenever possible.

List of Separator

Use this option to separate the parts in a same row either with a comma (‘,’) or space (‘ ‘) .

Exclude Prefixes

Use this option to restrict listing a specific part or type of part in the BOM. Specify part reference prefixes for parts you do not want to include in the report. For more than one type of part references, write the part reference prefixes separated with space as shown in the following figure:

image

Figure 14: CIS BOM- Exclude Prefixes Example

List Relational Data Fields

Use this option to add relational database properties to transfer the data from a relational table to a CIS BOM report. This option is available only if Relational table configuration has been done. Selecting this field populates the relation table properties in the Select Property List. A Relational table’s properties can be added to Output Format by selecting the properties and selecting the Add button

image

Figure 15: CIS BOM- Relational Data Field

All the relation properties are listed vertically, by default. You can also list the relational property values horizontally by selecting the Horizontal Output option. This option along with the Max Rows fields can be used to select how many relational properties (per part) are required in the BOM.

Output Mechanical Part Data:

You can obtain the details of mechanical parts and assemblies

associated with the electrical part used in the design. For example, a design may have a Transformer which has 4 screws/washers. In such a case, CIS allows to add the mechanical part details with minimal additional effort. The database needs to have two additional tables containing the details of the mechanical parts and assemblies used for the electrical parts. Mechanical part details have to be added for every required part number. This type of customization is possible using the Output Mechanical Part Data option.

image

Figure 16: CIS BOM- Mechanical Part Data

With the Mechanical parts only and Both mechanical parts and assemblies options you can choose the composition of your BOM.

Scope:

Sometime there are critical sections within the design (like a specific block) which drives the product’s timeline w.r.t cost, part availability, etc. You can define the scope your BOM report to a selected set of pages or the entire design using the options under Scope. This section works same as Capture BOM explained in Figure 3.

image

Figure 17: CIS BOM- Scope

Variants:

A design can have multiple variants. You can create a single report of the

desired variant names by selecting the names from the Variant list, and checking the Merge BOM Reports option.

The resultant report will contain the selected BOM variant data, separated by variant names in the same report. Use the Ctrl key for multiple selection from the list of variants.

Note: Sorting of report is not possible when merge BOM reports is selected.

Variant Not Stuffed QTY 0 displayed

Use this option to list the parts not present in a specific Variant with quantity as 0 or opt not to list that part at all. Check this to list the parts with quantity as 0.

image

Figure 18: CIS BOM- Variants

Export BOM to Excel

Use this option to export the BOM to MS-Excel directly from within the tool.

Checking the option opens the CIS Standard BOM in MS-Excel. Else, the BOM opens within Capture GUI which can be saved in any of the following formats from File -- Save as menu;

  • Text tab delimited format (*.BOM)

  • Excel delimited format (*.CSV)

  • Access format (*.MDB)

  • Formatted Comma Delimited File (*.fwc)

Note: Configuring mechanical table in CIS is beyond the scope of this document. To have an overview of Mechanical table and how to add mechanical part details in CIS BOM, watch the attached demos;

  1. OrCAD_MechBOM.htm

  2. CIS_Mechpart_Support.htm

To configure the mechanical table in CIS, refer to the topic Including Mechanical Parts and Assemblies in Standard CIS BOM in the OrCAD CIS User Guide.

TOC


Variant Reports

A Variant Report can be used when you only need to see the Variant content in the report and not the core design.

image

Figure 19: Variant Report GUI

Variant report can be formatted to select the properties and their sequence in the Variant report from the Select properties and Output Format sections. The formatting can be saved for later use with a Template Name.

In addition to reporting properties for selected variant, Variant Report provides following flexibility to users:

  • Variant Comparison on Part Number
  • Display Core Design Properties

Variant Comparison on Part Number: This check box lists the part number of all the variant parts in parallel columns in the same report. A single report contains the part numbers (from the core design) of all the parts and either the Part Number or the Do Not Stuff information of the variant parts and can be compared easily as shown in following image:

image

Figure 20: Variant Report- Showing Variant Comparison for Part Number

Display Core Design properties: Checking this option will display the core design property value enclosed within square brackets along with the variant property value. This option provides easy comparison between the core design and the variant.

In the following report, the value of the capacitor is 3 and cap300 is its footprint in the core design while 0.1uf and smdcap respectively is in variant#1.

image

Figure 21: Variant Report- Showing Core design and Variant Value

TOC


Crystal Reports

Crystal Reports is a powerful, dynamic and widely-used report design software solution from SAP Business Objects. Crystal Reports can be used in conjunction with Capture CIS to make customized report templates with more advanced features than the standard CIS bill of materials, including precision formatting and formulas that total, filter, and analyze data for highly specific results.

Note: Crystal Reports should be installed on a system with CIS to create Crystal Reports templates beyond what is supplied with Capture CIS. Search for SAP Business Objects on the internet to find web sites for reseller information about Crystal Report.

Once Crystal Reports templates have been created, any CIS user with access to them can generate, preview, print, and export reports with their design’s database part information from within CIS. They will not need to have copies of Crystal Reports installed locally on their workstations to use these templates.

The steps to create Crystal Reports templates are:

  1. Create an Access database bill of materials (.MDB) file using a standard CIS Bill Of Materials.
  2. Create report template (.RPT) files in Crystal Reports using the Access database file.

  3. Store the Crystal Reports template files where CIS can use them.

image

Figure 22: Crystal Report GUI

TOC


What is a Variant?

Market competition often drives designs which differ from each other by a small amount. These differences can be caused by the need to customize for targeted market segments, destination country, or feature/function set (like power level, emissions standards, etc.). These differences are often small and are made of incremental changes on the core design. For example, there might a need of two designs USA and India that have only one difference, which is in the resistance value of one resistor. However, creating these differences is often difficult. Designer can end up repeating the whole design cycle for each design and then generating BOM for respective designs.

The following image shows a variant design and the parts which are not stuffed in this variant are grayed out. Figure 24 shows a design viewed in Variant View mode.

image

Figure 23: Variant- Select Design Variant

The row highlighted in pink in Property Editor implies that this part property has a different value in the core design, which means that either this part is not stuffed, as in this case, or the particular property has a different value in variant from the core design part. For example, there can be a condition where a resistor has 10k value in the core design, but 20k in Variant design.

image

Figure 24: Variant- Variant View of Schematic of Bench_Allego.dsn

In Part Manager, variant appears as shown in the following image:

image

Figure 25: Variant Part Manager

Capture CIS allows to create and manage BOM of designs that are different from each other by a small difference by creating Variants. You do not need to maintain any other file for the design to obtain different Variant BOM from the core design. Because the design variations are captured within a single project, they can be viewed as variant information on a schematic page. You can preview and print variant schematic sheets, and create variant bills of materials without maintaining separate designs.

Properties of parts which are not present in variant are listed as ‘Do Not Stuff’ in the CIS BOM.

image

Figure 26: Variant- CSI BOM showing Do Not Stuff Parts

This text can be change to another user defined value at Options > CIS Configuration > Setup > Administrative Preferences tab.

Here, change the value of ‘part Not Present Display Value’ under Design Variants section.

image

Figure 27: Variant- Do Not Stuff text setting

Sometimes it is required to see the part number of the Do Not Stuff parts in CIS BOM as shown in image 23. For this, executed the following command in Capture Command Window

SetOptionString CisBomDisplayPartNumberForDNS TRUE

NOTE: TCL Commands are case sensitive.

image

Figure 28: Capture Command Window

Its adds following entry under [preferences] section in capture.ini file.

CisBomDisplayPartNumberForDNS=TRUE

To know more about how to create a design variant, new group, sub-groups, refer to the Creating BOM variants for your core design section of the OrCAD CIS User Guide.

TOC


Relational Database and its Configuration

Relational table is an additional table in a database which has properties/information about the parts present in the main part table. Any organization can opt to maintain a relational table in its database for some particular type of part information. One unique property common to both the main part table and the relational table is used to map the relation between the main part table and the relational table.

image

Figure 29: Relational Database- Property Mapping in MS-Access

As shown in the previous figure, the Part Number property has been used to map the main part tables (Capacitor and Resistor) with the Relation table VENDOR. This mapping is intrinsic to the database and has to be done by the database administrator.

image

Figure 30: Relational Database- Tables

If any organization has a relational database in use, CIS displays the relational table fields in CIS Explorer as well. And the relational table data can be transferred to the CIS BOM report.

image

Figure 31 Relational Database- CIS Explorer View

The SPB installation provides a sample relation database and its configuration file (.dbc file) present at <Install_location>\tools\capture\samples\CIS_db\RELDB.MDB and Relational.DBC.

Configure the ODBC connection for RELDB.MDB with Data Source Name as

Relational1650 and browse to Relational.dbc in CIS configuration to use this test relational database.

TOC


Relational Table Configuration

Other than the normal ODBC configuration for regular part tables of the database, following steps need to be performed to configure the relational tables of a database;

  1. In Capture CIS, go to menu Options > CIS Configuration > Setup > Relational Database.

The Configure Database dialogue box is displayed.

image

Figure 32: Relational Database- Relational Table Configuration

The Set Relational Data table contains a table with the following columns;

  1. Primary Table Name: Lists the configured part tables.
  2. Primary Key: Selects the property name which has been used to define the relation between main part table and relational table in the database.
    For example, Part Number as shown in Figure 30.
  3. Relational Table: Select the relational table for that part table as it has been configured in the relational setup in the database. In Figure 27, VENDOR is the relation table for both Capacitor and Resistor tables.
  4. View Name: The name assigned here is visible in View menu of CIS explorer.

Complete the configuration for the above fields for the desired main part tables and then relational tables can be seen in CIS explorer as shown in Figure 31.

Note: Relational table is not to be configured like main part tables in the Part Database tab of the Configure Database dialogue box. Relational tables are listed here but are not to be configured as shown in the following image:

image

Figure 33: Relational Database- Vendor Table

TOC


References

  • OrCAD Capture User Guide

    • <Installation_dir>\doc\cap_ug\cap_ug.pdf

  • OrCAD CIS User Guide

    • <Installation_dir>\doc\cisug\cisug.pdf

  • Demonstrations:

    • <Installation_dir\doc\cisug\demo\OrCAD_MechBOM.htm

    • <Installation_dir\doc\cisug\demo\Using_the_Component_Information_System.htm

    • <Installation_dir\doc\cisug\demo\Viewing_Design_Variants_on_a_Schematic_Page.htm